Forum software is responding slowly

Messages from the admin team about how the forum operates. Please read them!
User avatar
Kim O'Hara
Former staff member
Posts: 3366
Joined: Fri Nov 16, 2012 1:09 am
Location: North Queensland, Australia

Forum software is responding slowly

Postby Kim O'Hara » Sun Feb 14, 2016 11:34 am

For quite a while now we have had a minor problem with the forum software - or perhaps the server hosting it.
It shows up as a very slow response to clicking on the "Submit" button, both in posting to the forum and in sending PM's.
If your device shows you a progress bar, it will look like it 'got stuck half-way'.
Please don't panic!
If you do nothing, it will eventually complete the process and move on to the next screen in whatever you were doing - back to the forum or PM's.
If you think it hasn't worked, and click "Submit" again (and again and again), multiple copies of your post or PM will be submitted - and you will still have to wait before getting back to the forum. That's fairly annoying to everyone, including yourself, so please don't do it.

We're working on a solution (and welcome constructive suggestions from anyone who knows a bit about forum software).
Meanwhile, the best work-around I have discovered is to open a new window and continue your participation in that one while the first one is stalled. In fact, if you go back to the page you submitted to, you will usually find that the submission is already completed although your old window doesn't say so. :shrug:

:namaste:
Kim

User avatar
Wayfarer
Posts: 3209
Joined: Sun May 27, 2012 8:31 am
Location: Sydney AU

Re: Forum software is responding slowly

Postby Wayfarer » Sun Feb 14, 2016 12:22 pm

My hunch would be some issue with a server configuration. If the service provider has a helpdesk then it might be a good time to raise a ticket if you haven't already done so. (Oh, and that 'submit' worked pretty well instantaneously, but I have noticed the long latency period recently.)
In the beginner's mind there are many possibilities; in the expert's mind there are few ~ Suzuki-roshi

User avatar
Kim O'Hara
Former staff member
Posts: 3366
Joined: Fri Nov 16, 2012 1:09 am
Location: North Queensland, Australia

Re: Forum software is responding slowly

Postby Kim O'Hara » Sun Feb 14, 2016 12:45 pm

Thanks, Wayfarer.
Yes, sometimes it works immediately for me, too - but not often.

:namaste:
Kim

Simon E.
Posts: 4372
Joined: Tue May 15, 2012 11:09 am

Re: Forum software is responding slowly

Postby Simon E. » Sun Feb 14, 2016 1:08 pm

Thanks for the heads-up...I had noticed, but being a techno-moron I assumed it was something to do with my chrome-book... :smile:
" My heart's in the Highlands
my heart is not here.
My heart's in the Highlands
chasing the deer."

Robert V.C. Burns.

User avatar
Kim O'Hara
Former staff member
Posts: 3366
Joined: Fri Nov 16, 2012 1:09 am
Location: North Queensland, Australia

Re: Forum software is responding slowly

Postby Kim O'Hara » Fri Jun 03, 2016 4:43 am

Just a reminder -
The forum software is still responding slowly, especially when you click on 'Submit'.
Please be patient. It will get there eventually! Repeatedly hitting 'Submit' results in multiple posts, PMs, etc., which is a nuisance to everyone.

If you're in a hurry to move on, it is quite safe to open a new window (on DW or any other site) and keep working. Our software will keep on grinding away in the background - and you may well find that the new window shows your action has already been processed, since the slowdown is in refreshing your browser window rather than in updating the forum.

:thanks:

Kim

User avatar
Karma Dorje
Posts: 1195
Joined: Thu Sep 01, 2011 10:35 pm

Re: Forum software is responding slowly

Postby Karma Dorje » Fri Jun 03, 2016 7:48 am

Admin_PC wrote:
re: Forum Software
We're having a number of ongoing issues, including a complete lack of email notification. We have people working on these issues in the background, but they're kind of a separate effort from day-to-day moderation/administration tasks. The forum software's a little bit out of date to be perfectly honest. We had problems losing a large amount of forum data in the past when an upgrade was attempted. The reluctance to lose any additional forum data is why the current efforts are somewhat slow-going. "Better safe than sorry" as they say. If I find out any news on the progress of these efforts, I'll do my best to keep people posted.[/color]


Contact me if you need any additional technical help with this issue. I am happy to help troubleshoot as time permits.
"Some people believe football is a matter of life and death, I am very disappointed with that attitude. I can assure you it is much, much more important than that"
—Bill Shankly

User avatar
Admin_PC
Site Admin
Posts: 3404
Joined: Wed Sep 19, 2012 11:17 pm
Location: Texas, USA

Re: Forum software is responding slowly

Postby Admin_PC » Sat Jun 04, 2016 4:26 am

Unfortunately this issue is a bit beyond my pay grade. Thanks for the offer.
月影の いたらぬ里は なけれども 眺むる人の 心にぞすむ
法然上人

emaho
Posts: 646
Joined: Sun May 06, 2012 8:33 pm

Re: Forum software is responding slowly

Postby emaho » Sun Mar 12, 2017 8:46 pm

I keep noticing that if I open the forum in a second browser tab I can already read my post, while the first tab in which I submitted it is still without a response from the server. So very obviously whatever causes the delay happens after the post has been successfully saved in the database.

Secondly, there still seems to be a general issue with email notifications of any kind which, frankly, aren't working at all.

My guess is that the delay when posts are submitted is caused by the server unsuccessfully trying to send out email notifications to all those who have subscribed to the topic. (A quick test would be to open a test thread which doesn't have any subscribers yet and see if responses to it are also delayed. (Don't know if it's possible to subscribe to boards.))

So the solution would be to finally fix the email server problem, or, as a workaround, to deactivate all email notification functions.




P.S. wow, I just edited this post and it was successfully submitted without any delay. I'm guessing that the edit function does not trigger email notifications to subscribers?
"Do yourself a favor and get out of Samsara!" Dudjom Rinpoche, Counsels From My Heart

Derek
Posts: 49
Joined: Mon Aug 26, 2013 4:51 pm

Re: Forum software is responding slowly

Postby Derek » Tue Apr 04, 2017 4:49 pm

Since the forum is just phpBB, it should be possible to search for people also having slow responses when posting to a phpBB forum. For example, my search came up with this as the first result:

https://www.phpbb.com/community/viewtop ... &t=2374061

That thread suggests that changing the "Email package size" would be one thing to try. More searching might yield more suggested fixes.

User avatar
Ayu
Global Moderator
Posts: 6180
Joined: Mon Oct 29, 2012 8:25 am
Location: Europe
Contact:

Re: Forum software is responding slowly

Postby Ayu » Wed Apr 05, 2017 2:25 pm

Topic locked for some time.
Sorry for any inconvenience. :namaste:
I have decided to stick with love.
Hate is too great a burden to bear.
- Martin Luther King, Jr. -


Return to “Announcements”

Who is online

Users browsing this forum: No registered users and 2 guests